• Send Files page stuck at "Loading"

    By Pierre Passin 10 years ago

    I must be doing something wrong but I am not sure what. When I try to upload a file, the page becomes grey but nothing happens

    I have dojo 1.5 running, it seems no error on the page, made sure I had large upload limit on the Internet site document.

    Anything somebody can think of ? Thanks

    • Eventually it says "Could not find upload document"

      By Pierre Passin 10 years ago
      • It seems linked to the size of the attachement

        By Pierre Passin 10 years ago

        6 MB works fine but 30MB does not

        • Have you enabled your domino server to allow large file uploads ?

          By Declan Lynch 10 years ago

          Have a read of this...

          http://www.qtzar.com/blogs/qtzar.nsf/Blog.xsp?entry=5xtsv09wjr40

          • Better now but unfortunately it freezes at the end of the upload.

            By Pierre Passin 10 years ago

            I had indeed missed the "Protocol Limitation" portion. In the mean time I create the document via an improvised Notes interface.

          • To be able to upload large files I had to enable large files on serverdocument even if I am using Internet Sites

            By Danne Lindskog 10 years ago

            Had problems being able to upload larger files than 10MB, but after updating the server document as well as the Internet Site document it worked.

            Is this a bug on Domino 8.5.2?

            I was sure that when I'm using Internet sites it would be enough to update the internet site document, but I had to update it on the server document (set it to 0) as well.

            using Firefox to upload....

          • Could not find upload document

            By CaySal Lackey 10 years ago

            I am running Domino 8.5.2 fp2 on Windows 2003. I am using File Sendr v1.1.0, and made sure to sign the application. I have followed the instructions for updating dojo 1.5 and 1.6. I have installed xpages Extension library 8.5.2.201104090234NTF.

            I have I am having problem uploading files that are larger than 10 meg, less than 10 meg works fine. My server uses internet site documents and I have changed the maximum post data. I have also changed the HTTP protocol limit max size. I also changed the xpage application properties file upload limit. After making these changes I restarted my server.



            Here is a snip from my log file. Does anyone know how to fix my problem so I can upload files larger than 10 meg? Also upload is very slow but download is very quick. Are there any go fast = yes parameters that I should know about for this application?



            04/28/2011 02:50:05 PM HTTP JVM: processUpload.go : Started

            04/28/2011 02:50:05 PM HTTP JVM: processUpload.go : Could Not Find Upload Document

            04/28/2011 02:50:49 PM HTTP JVM: DOJOX.Form.FileUpload To Amazon S3 : Started

            04/28/2011 02:50:49 PM HTTP JVM: DOJOX.Form.FileUpload To Amazon S3 : Load com.amazonaws package

            04/28/2011 02:50:49 PM HTTP JVM: DOJOX.Form.FileUpload To Amazon S3 : get Access To The Uploaded File

            04/28/2011 02:50:50 PM HTTP JVM: DOJOX.Form.FileUpload To Amazon S3 : Upload Key : w0cq7hpb0y68

            04/28/2011 02:50:50 PM HTTP JVM: DOJOX.Form.FileUpload To Amazon S3 : Upload Days : 14

            04/28/2011 02:50:50 PM HTTP JVM: DOJOX.Form.FileUpload To Amazon S3 : Temporary File Name : Drop.exe

            04/28/2011 02:50:50 PM HTTP JVM: DOJOX.Form.FileUpload To Amazon S3 : Corrected File Name : C:\WINDOWS\TEMP\notesAE5DC0\xspupload\Drop.exe

    • File dosen't send

      By Roberto Zucca 10 years ago

      I have the same problem , help me please.

    • Same Problem here

      By Ingo Spichal 10 years ago

      Tested in IE 8 and Firefox 3.6.13.

       

      In IE 8 I get a JavaScript Error and the load process stucks :

      Meldung: Hexadezimalziffer erwartet
      Zeile: 1
      Zeichen: 194
      Code: 0
      URI: http:///test/filesend.nsf/sendFiles.xsp

      I think it translates to "hexadecimal number expected"

       


      In Firefox I used FireBug to track the load process. I tested different files, varying filesizes, etc. It seems that it is a problem with certain files but I couldn't find a rule for that (e.g. filesize greater than x MB)

      This is the error :

      * doUpload File Dropbox 1.0.10.exe
      single file - do upload, fieldName flashUploadFiles
      ** onProgress ** 0.004453684292934125
      ioErrorHandler: name=Dropbox 1.0.10.exe event=[IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #2038"]

      After that a timer ticks from 1 to 599 (10 minutes). During this time the browser "hangs". What happens then depends on if you try to upload one or more files.

      If this is the only file, you get an error "Could not find File Upload Document" and the browser hangs (page is inactive).

      If there are more than one file, the process continues with the next file or saves and sends the mail. The file with the error is missing in the upload document.

      • Now working in FF,still problem in IE 8

        By Ingo Spichal 10 years ago

        The response by Pierre Passin was the key. After setting the Maximum size for POST Data to 0 (unlimited) I was able to upload files with Firefox 3.6.13. I tested it multiple times without any error.

        In IE 8 however, the error remains. The files are all uploaded but the page stucks after that.

    • Send Files page stuck at "Loading"

      By Lars Leutheusser 10 years ago

      I have the same problem. The server-log shows the folowing:

      01/24/2011 03:59:10 PM  HTTP JVM: DOJOX.Form.FileUpload To Amazon S3 : Started
      01/24/2011 03:59:10 PM  HTTP JVM: DOJOX.Form.FileUpload To Amazon S3 : Load com.amazonaws package
      01/24/2011 03:59:10 PM  HTTP JVM: DOJOX.Form.FileUpload To Amazon S3 : get Access To The Uploaded File
      01/24/2011 03:59:10 PM  HTTP JVM: DOJOX.Form.FileUpload To Amazon S3 : Upload Key :
      01/24/2011 03:59:10 PM  HTTP JVM: DOJOX.Form.FileUpload To Amazon S3 : Upload Days : 14
      01/24/2011 03:59:10 PM  HTTP JVM: error: com.ibm.jscript.InterpretException: Script interpreter error, line=23, col=89: 'fileData' is null

      • I am having the same problem with the File Upload failing.

        By Wright Furman 10 years ago

        I am running 8.5.2 with FP1 but am still have the same problems as noted in this thread with file upload failing.

        I followed your instructions:

        I have set up large file transfers in both places, I have loaded the extension libraries, I installed dojo-1.5.0 and copied the ibm subdirectory from dojo-1.4.3 folder to the dojo-1.5.0 directory and removed the *.gz files, I set myself up with the config role in the ACL, I opened the web site from a browser and created the default configuration document and saved all of the settings.

        Are there any other known issues?  Does it run with 8.5.2FP1?

        • Check Protocol Limitaion part in the server document

          By Pierre Passin 10 years ago

          There ids a field there to update for large uploads.

          • Protocol limitation

            By Wright Furman 10 years ago

            I already set the maximum size of request in the server document Internet Protocols/HTTP/ HTTP Protocol Limits section of the Server document to 2097152.  I also set the Internet Site document for my server Domino Web Engine/Post Data/Maximum Post Data to 2097152.  I also set the application properties of the XPage to 2097152.

            None of that made a difference.  Does this work with Internet Site documents?

            • Working in Firefox but not IE

              By Wright Furman 10 years ago

              I set the minimum supported version to 8.5.2 in the  Application Properties.  It is now working in Firefox but not in IE I still get the "Expected Hexidecimal digit" error from the sendfiles.xsp.

              I have cleared my cached and restarted HTTP to no avail.

              • Do you have plans to support IE?

                By Torben S Johansen 10 years ago

                Do you have plans to support IE?

                The app looks very nice, - I would love to use it!

                Best regards
                Torben Johansen

    • Same problem : doesn't work with IE8

      By Thierry CORNU 10 years ago

      Same problem : doesn't work with IE8. Page stay grayed out with exclamation point indicates an error about something like hexadecimal needed (?). Work with Chrome.

      Tested with 0 or not in the two fields HTTP/ POST in configuration document for the server.

    • Hang loading files

      By Luciano De Rugna 10 years ago

      Pay attention with long or complicated file name. it could stop sending files.

      Just try change name file. Hope it helps.

      Luciano