• Can't get v1.3 working on Windows 7 desktop and Remote Windows 2008 VM

    By Michael Residori 3 years ago

    Hi,

    I am unable to get the latest version of the SDK working when using a remote VM. I keep getting this error when clicking “Debug” in the debug configuration:.

    I've gone through the documentation a few times and don't see anything wrong. However, your documentation shows file locations in a Linux format, not Windows. This format extends to the config.ini file so I'm wondering if that's the issue?

    Anway, here are more screen shots of my configuration:

    Shared drives as seen from local machine. Michael is local machine and VMMAXDEV is Domino VM.

    Shared drives as seen from VM. Also shows Y drive mapped to share on local

    SDK setup

    PDE debug configuration

    Prompt when launching PDE config

    Then, of course I get the error shown in the first screen shot. Here's the config.ini file that gets created on my local drive in D:\eclipse\workspace.metadata.plugins\org.eclipse.pde.core\HTTP OSGi Framework

    Created by OpenNTF XPages SDK

    Sun Jan 08 15:16:00 EST 2017

    osgi.bundles=reference\:file\:C\:/Domino/data/domino/workspace/.config/domino/eclipse/plugins/com.ibm.domino.osgi.sharedlib_1.0.0.jar
    osgi.install.area=file\:C\:/Domino/osgi/rcp/eclipse
    osgi.bundles.defaultStartLevel=4
    osgi.framework=file\://Vmmaxdev/c/Domino/osgi/rcp/eclipse/plugins/org.eclipse.osgi_3.4.3.R34x_v20081215-1030-RCP20130829-1400.jar
    osgi.configuration.cascaded=false

    No PDE file is created on the remote server.

    Please let me know if you need any additional information. Any assistance you can provide would be greatly appreciated.

    Thanks in advance,
    Mike

    • By Michael Residori 3 years ago

      Sorry… forgot to include basic client/server info

      Using Eclipse Mars.2 Release 4.5.2
      Domino server 9.0.1 FP7

    • By Serdar Basegmez 3 years ago

      Hello Michael,

      Nice to see a new use case. I would speculate if the problem is the value on the preferences “Shared directory from local”.

      As far as I understood, the Y: mapping goes to the D:\Eclipse folder on your Windows 7 machine, right? Then this field should point to “D:\Eclipse” folder.

      When we try to point plugin files, Eclipse has a mapping starting with “D:\Eclipse\Workspace...“. We should be able to replace “D:\Eclipse” part with “Y:". That's why the “Shared directory from local” should point to the junction mapped by the remote machine.

      Can you try that?

      Thx.

      • By Michael Residori 3 years ago

        Hi Serdar,

        Thanks for the quick reply. Your understanding of the mapping is correct. The D:\eclipse folder on my local Win7 machine is shared and the Y:\ drive on my VM is mapped to that share. All my project files are in the D:\eclipse\workspace folder.

        I tried your suggestion but I still get the same “Unable to convert…” error. Here's a screen shot of my updated preferences page along with a couple showing more info on the shared/mapped drives.

        Y:\ drive on VM mapped to shared “eclipse” folder on local

        Shared “eclipse” folder on local

        I double checked the security settings on the shared folders thinking that might be a problem and made sure “Everybody” had full read/write access on both the VM and local machines but that didn't make a difference.

        Any other suggestions?

        Thanks,

        • By Serdar Basegmez 3 years ago

          Can you also try using “D:/eclipse”?

          • By Michael Residori 3 years ago

            Sorry for the delayed reply but I had some things come up and I'm just now able to get back to this. Almost there, but not quite…

            Your suggestion of using a forward slash did get rid of the dialog error. But, just so you know, I used the “Browse…” button which automatically inserts backslashes into the file path.

            After that I got similar warnings when running the debug configuration in the eclipse log. So, I figured I would try replace the backslashes inserted by all the “Browse…” buttons and the warnings disappeared. Here's a screenshot of my new configuration:

            The problem now is an error in the server console after restarting the http process:

            Here's what it looks like from the mapped Y:\ drive on the Domino server:

            As you can see there is no links folder or shared.link file. Is that supposed to be generated when the debug configuration is run? Any ideas how to fix this issue?

            As always your assistance is greatly appreciated!

            • By Serdar Basegmez 3 years ago

              I will take this scenario back to my development environment. This replacement routine needs to be fixed.

              However, I can't make this change till weekend. Will get back with a fix hopefully.

              Thanks for bringing up this issue.

              • By Michael Residori 3 years ago

                Understood. Let me know if you need anything else from my end.

            • By Serdar Basegmez 3 years ago

              Michael,

              This latest error also happened for another user. We solved it by changing some security settings. I have added that to the documentation, in the Gotchas section.

              https://stash.openntf.org/projects/XSPSDK/repos/xpagessdk/browse/Readme.md

              Can you try that on the VM Windows?

              • By Michael Residori 2 years ago

                Hi Serdar,

                I know it's been quite some time but I had a number of things come up and wasn't able to get back to this until today. I did follow your suggestions and it worked!

                The biggest problem I had with it was that you mention you have to run the server as an application rather than as a service. That was a show stopper for me because when you logout of the Windows server the Domino server shuts down.

                As you know you can't access a mapped drive from Domino when it's running as a service. However, after playing around a bit I found that you CAN map a drive from within the Domino server console with the “net use” command. Just type this in the Domino console using your own specific values

                $net use y: \michael\eclipse mypassword/user:residori\mike

                restart HTTP and it works! No need to run Domino as an application. The only caveat is you have to re-map the drive each time you start up the server. There is a/persistent:yes argument for net use but it didn't work in this case.

                I'm good to go now. Thanks for all your assistance and quick replies to this thread!!

                • By Serdar Basegmez 2 years ago

                  Michael, Thx for the update! It will certainly help other users.

                  Yes, mapped drive is a big problem. I use my own VM so running Domino as Application is not big deal for me.