• Cannot Find Library

    By John Q Parker 5 years ago

    I have setup Openlog.nsf (signed, setup ACL, modified LogDbName wherever I could find it), installed your updateSite, and rebooted the server.
    If I try to load your demo db, all I get are 500 errors and this in the log:
    HTTP JVM: com.ibm.xsp.webapp.FacesServlet$ExtendedServletException: com.ibm.xsp.FacesExceptionEx: Cannot find the library com.paulwithers.openLog.library.StarterLibrary, required by the application/openlogjava.nsf

    I tried without and then with the script libraries 'OpenLogClass' and 'OpenLogFunctions' from openlog.nsf copied into your demo db, same result. What have I missed?

    • By Paul S Withers 5 years ago

      OpenLogClass and OpenLogFunctions are not relevant for this. They're a Java class for use in Java agents and a LotusScript library.

      It's not finding the OSGi plugin (or extension library) in the Update Site database. As for the Extension Library, it's worth checking the steps in Chapter 2 of XPages Extension Library book.

      tell http osgi diag com.paulwithers.openLog/ tell http osgi ss com.paulwithers.openLog will tell whether the library is installed or there are any dependencies missing. There should not be any.

      The main thing to check is that the OSGI_HTTP_DYNAMIC_BUNDLES notes.ini setting has been added and maps to the relevant update site database. If the notes.ini variable is set, when HTTP starts the console will have the message “NSF Based plugins are being installed in the OSGi runtime.”

      • By John Q Parker 5 years ago

        OK, it seems we have 8.5.2 of the extlib. I will upgrade and see if that fixes the problem, thanks.