• Installed the 4.01 toolbar but get an error when I try to go to examine the viewScope (or any other tab)

    By Bill Fox 5 years ago

    When I click the View Scope tab I get this error:

    Error while executing JavaScript action expression

    Script interpreter error, line=1, col=6: Error calling
    method 'setActiveTab(string)' on java class
    'org.openntf.xsp.debugtoolbar.beans.DebugToolbarBean'

    JavaScript code

       1: dBar.setActiveTab("viewScope");
    

    The server has an update site on it and looks to be loading the OSGI correctly. The toolBar displays correctly on the XPage. Is there something else I need to do?

    • By Bill Fox 5 years ago

      Further on the server I did this:

      tell http osgi ss org.openntf.xsp.debugtoolbar
      09/05/2014 11:23:29 AM Framework is launched.
      09/05/2014 11:23:29 AM id State Bundle
      09/05/2014 11:23:29 AM 13 «LAZY» org.openntf.xsp.debugtoolbar_1.1.0.201403092102

      So I believe that is the correct version and it is installed.

      • By Mark Leusink 5 years ago

        Sounds like you're loading the older ccDebugToolbar custom control on that page. Just delete that from the database and use the debug toolbar from the plugin: it's in the controls list in a drawer called “Debugging”.

        • By Bill Fox 5 years ago

          Very strange. I was using the 3 DeBug ToolBar but removed the all the elements of the old toolBar from the database. When I expand the debugging draw there are two XPAges DeBug ToolBar entries - one with a little bug icon and one with a small red Square. So I'm guessing that there is some of the old ToolBar hanging around somewhere.

          • By Mark Leusink 5 years ago

            Having 2 entries in the Debugging drawer is expected: there's a bug in Designer causing it to show up twice. Unfortunately I can't fix that.

        • By Bill Fox 5 years ago

          If I write some messages dBar.info(“My Message”) they show up un the Messages section and I can open that tab of the tool bar also can open the Java tab with any of the scoped variables I get the error above, When I try opening the inspector I get a different error:
          javax.faces.el.EvaluationException: Error getting
          property 'inspectorExpression' from bean of type
          org.openntf.xsp.debugtoolbar.beans.DebugToolbarBean:
          java.lang.NullPointerException

          Error getting property 'inspectorExpression' from bean
          of type org.openntf.xsp.debugtoolbar.beans.DebugToolbarBean:
          java.lang.NullPointerException

          So I'm really lost on what to do next.

          • By Mark Leusink 5 years ago

            Hmmm. No clue actually…

            Can you try it in a new database? Just enable the plugin and drag the toolbar from the Debugging drawer to a new XPage.

            • By Bill Fox 5 years ago

              I have to go onto something else at least the messages work so I will try you suggestion and get back to you. Seems odd I would think that the import would either work or not at all, but then …..

            • By Bill Fox 5 years ago

              Created a new database on the server (Domino 9.0) and created a New XPage (Plain Jane no data). I added the debug toolbar from the Debugging drawer. and a couple lines of text. Opened the XPage. I could open the Messages (I had not created any) but when I clicked on ViewScope variable I get a popup window with this message.


              TestXPage

              An error occurred while updating some of the page.
              Unable to load http://127.0.0.1:60185/xsp/XPages/TestDebug.nsf/TestXPage.xsp?1399655941%3FOpenXPage&xspRunningContext=Notes&

              $$ajaxid=view%3A_id1%3A_id2%3AdebugToolbar status: 500

              OK

              When I try to open the database in Chrome the page does not load and I get this message:

              Page Name:/xpWFSDemo.xsp
              Control Id: linkTabMessages

              Exception

              Error while executing JavaScript computed expression
              Script interpreter error, line=1, col=21: Unknown member 'getNumMessages' in Java class 'eu.linqed.debugtoolbar.DebugToolbar'

              JavaScript code

                 1: “messages (” + dBar.getNumMessages() + “/” + dBar.getNumErrors() + “)“;
              

              the XPage xpWFSDemo.xsp has the debug toolbar on it. In designer it all looks to be loading the 4.0.1 toolbar.

              don't know what to do next. I suppose I could take the 4.0.1 out of the update site and try loading it again?????

              • By Mark Leusink 5 years ago

                Don't think that would help.

                It's weird that you get a message mentioning the 'eu.linqed.debugtoolbar' package because that's not used anywhere in the plugin.

                Does the new app still have a faces-config entry for the debugtoolbar? Or did you add any other resources related to the toolbar?

                • By Bill Fox 5 years ago

                  The faces-config has this in it





                  So I'm at a loss on this. Is it possible for there to be any artifacts left over on the server?
                  Because I had been meaning to do this for awhile I uninstalled Notes on my client then moved everything that was left behind to a new location. I then installed 9.0 client and designer, I then copied Names.nsf, Notes.ini from my backup into the fresh install, then imported the 9.0.1 Extension Library and the 4.0.1 debug toolbar. Copied the database I was concerned with into the new client. removed the debug toolbar Custom Control, the Java Libraries, JavaScript. Opened the database in the Package explorer and removed the reference in the faces-config. Then set the DB property to use the debug toolbar library.
                  Still got the same result. Created a new database and copied all the design XPages and CC from the old DB into the New Database. Same result.
                  On the server I have an update Site that has ExtLib 9.0.1 and the debug 4.0.1 loaded. It appears to be loading correctly and if I
                  tell http osgi ss org.openntf.debugtoolbar it get the message :

                  tell http osgi ss org.openntf.xsp.debugtoolbar
                  12/05/2014 10:36:18 AM Framework is launched.
                  12/05/2014 10:36:18 AM id State Bundle
                  12/05/2014 10:36:18 AM 13 ACTIVE org.openntf.xsp.debugtoolbar_1.1.0.201403092102
                  which appears to be correct. Is it possible for there to be some artifacts left behind on the server, I did have 3 installed there.

                  • By Mark Leusink 5 years ago

                    Hi Bill,

                    Weird issue. The server side seems to be correct. I can't think of a way that there are artefacts that were left behind.

                    Did you try copying the debug toolbar demo database that's in the download to the server and testing that?

                    • By Bill Fox 5 years ago

                      Will give that a try.

                    • By Bill Fox 5 years ago

                      Copied the DB to my local machine and opened it in designer. Opened the demoPage XPage in designer then selected run (Notes) got a message “Oops.. that wasn't suppose to happen”, replicated the Demo to my server and did the same thing, with the same result.

                      • By Mark Leusink 5 years ago

                        I'm pretty much out of options. I know that the debug toolbar definitely works in the Notes client or on the server. The eu.linqed references also don't make sense.

                        There must be something different in your environment compared to others, but I haven't got a clue what that is :-(

                        • By Bill Fox 5 years ago

                          Does 4.0.1 work with Notes 9.0 or does it require 9.0.1 - I can't upgrade to 9.0.1 for reasons beyond my control. I just uninstalled Notes on my laptop then did a clean install of 9.0 then imported the 4.0.1 created a local database and created a new XPage, added the toolbar - same result. I can't waste any more time on this I'm going back to 3 and get some productive work done.

                          • By Andreas Imnitzer 5 years ago

                            This is what I had in the faces-config of an app I had the same problem with:

                            xml version="1.0" encoding="UTF-8"?>

                            <faces-config>

                            <managed-bean id="dBar">

                            <managed-bean-name>dBarmanaged-bean-name>

                            <managed-bean-class>eu.linqed.debugtoolbar.DebugToolbar

                            managed-bean-class>

                            <managed-bean-scope>sessionmanaged-bean-scope>

                            managed-bean>

                            faces-config>


                            I removed the managed bean, saved it, and voila, it worked.