• Missing Libraries: org.openntf.domino.xsp.XspLibrary

    By Markus Langer 4 years ago

    I removed the old version and then installed the new Version 2.0 in my domino designer.
    After a restart I get an error in the xsp.properties. “Missing Libraries: org.openntf.domino.xsp.XspLibrary”.
    I tried it several times without success.

    What should I do?

    Many thanks.
    Markus

    • By Jesse Gallagher 4 years ago

      There are a couple potential causes that I've seen so far.

      One is if you have other lingering versions hanging around in Designer, which can be found in File -> Application -> Application Management, in the second section. Older releases didn't always have the same plugin IDs, and so can conflict.

      Another (and more likely, since you said you removed the old one already) possibility is the need to install a release of the 9.0.1 ExtLib from OpenNTF (it probably doesn't matter which). The 2.0.0 release of ODA has a dependency on IBM's DAS plugin, which is present in a Notes install but is not used by Designer, so the library plugin fails to load.

      • By Markus Langer 4 years ago

        You're right. I have installed the latest version of the ExtLib from OpenNTF and now it works fine.