• --encrypt has no effect

    By Christian Felsing 8 years ago

    Hello,

    I tried following to send a Notes encrypted mail:

    java -cp '/opt/notes-cli/CLENotes-4.1.1/lib' -jar '/opt/notes-cli/CLENotes-4.1.1/lib/jython.jar' -Djython.home='/opt/notes-cli/CLENotes-4.1.1/' -Dpython.path='/opt/notes-cli/CLENotes-4.1.1/lib:/opt/notes-cli/CLENotes-4.1.1/ext' -Djava.library.path='/opt/ibm/lotus/notes/' '/opt/notes-cli/CLENotes-4.1.1/lib/clenotes/clenotes.py' --server-name=notes1/sbroker --password=*** send --encrypt --sign --to="user/notes/DE" --subject="Hello world subject" --body="Blah Fasel Test"
    Command Line Email Client for Lotus Notes v4.1.1
    Copyright (C) 2002, 2010 by IBM Corporation.
    Licensed under the Apache License v2.0.

    Mail sent.
     

    Mail arrived, but was not encrypted. Due to security reasons it is fatal if mail is sent unencrypted w/o any warning.

    If I send mail with also installed Notes 8.5.2 client which provides libraries for my notescli installation, mail is sent encrypted.

    regards

    Christian

    • --encrypt effect

      By Sami Salkosuo 8 years ago

      Thanks for letting me know.

      Please try the following if it allows you to send encrypted mail:

      • Open Mail.py file in lib/clenotes-directory
      • Find following line: newMailDocument.setSignOnSend(True)
        and enter following in the new line: newMailDocument.sign()
      • Find following line: newMailDocument.save() and replace it with: newMailDocument.setSaveMessageOnSend(True)
         

      Does that send encrypted mail?

      For checking if encrypted mail can be sent to recipient, I try to find some way to check it. InfoCenter says this about when sending encrypted email :

      To encrypt a document when mailed, this method looks for the public key of each recipient in the Domino Directory. If it cannot find a recipient's public key, the method sends an unencrypted copy of the document to that recipient. All other recipients receive an encrypted copy of the document.

      • [Solved] Looks Good :-)

        By Christian Felsing 8 years ago

        Receiver sees now a mark in Properties->Encryption

        Thank you very much

        Christian