• clenotes --password option doesn't work with send

    By boson matter 7 years ago


    I am using clenotes 4.2.2 with IBM Lotus Notes client 8.5 (Release 8.5.1 FP1).
    You can see below that I have provided my password on the command line - but it still prompts for my password and when I enter my password, it gives an error anyways.
    <strong>CLENotes-4.2.2&gt;clenotes.cmd send --to=&quot;email@host.com&quot; --subject=&quot;test mail&quot; --password=xxxxmypwdxxxx</strong></div>
    Command Line Email Client for Lotus Notes v4.2.2
    Copyright (C) 2002, 2012 by IBM Corporation.
    Licensed under the Apache License v2.0.
    The ID file being used is: U:\Notes8\Data\xxxx_myuser_xxxx.id
    Enter password (press the Esc key to abort): <strong>&lt;I enter xxxxmypwdxxxx again&gt;</strong></div>
    <strong>Error executing command &#39;Mail.sendMail&#39;: getopt.GetoptError <u><em>,option --password not recognized,</em></u> &lt;traceback object at &nbsp;1&gt;</strong></div>
    Any help is much appreciated.
    Boson Matter.
    • --password before send

      By Sami Salkosuo 7 years ago


      Please use --password option before send-command like "clenotes --password=mypwd send". Password is global option meaning that it is used in all commands, not just send. That's why it's before send-command.