• Doesn't work for me on Redhat 7.2/R5.0.10

    By bernard j devlin 2 decades ago

    I tried 1.2 on Win32, and it seems to work fine. But when I tried the Linux version on two servers. At first it couldn't find the program, but afte I moved it there was no error when I typed 'load aclhelp log.nsf ?' , but there was also no output (I restarted the server just in case).

    • check permissions?

      By Ian Cherrill 2 decades ago


      Thanks for your comments. Without some sort of error message this problem might be difficult to track down. I haven't tested every Linux distribution and Notes5 or 6 combination so it is possible there is a problem with the combination you have. Have you now put the aclhelp program into the Notes program directory? Do the file permissions (execute, for example) match the other programs such as replica, compact, design etc?

      Regards, Ian

      • more info

        By bernard j devlin 2 decades ago

        Hi Ian,

        I ran it from the command line instead of the console, and this revealed the problem:


        $/opt/lotus/notes/latest/linux/aclhelp: error while loading shared libraries: libstdc++.so.5: cannot open shared object file: No such file or directory

        I searched for that library and it doesn't exist on my servers (I tried two of the same). However, when I installed aclhelp on my Mandrake 9.2 server, then it would run without this problem. Could it be that it was compiled with a compiler that is later than the libraries installed on platforms such as Redhat 7.2? I know that 7.2 seems like it is a bit ancient given the speed at which Redhat moves along, but AFAIK ND6 is not supported on versions of (e.g.) Redhat above 7.2 or SuSE 8.3.

        When I couldn't get Aclhelp to work yesterday I went to the Sandbox to see what was on offer there. And, as far as I can see, nothing comes even close to it. Thanks for producing something such a great piece of software.

        I will have a go and see if I can compile it myself for Redhat 7.2

        • Do I need Lotus C++ API to compile?

          By bernard j devlin 2 decades ago

          Just looking through the linux.mak file, and it looks to me like I need to have something like the Notes C++ SDK installed. Is that so?


          • C API

            By Ian Cherrill 2 decades ago

            Hi Bernard,

            Sorry for the delay in replying. To compile ACLHelp you will need the Lotus C API Toolkit which you can download for free from Lotus. I tend to use the R5 toolkit as there is no new function in R6 that ACLHelp uses, but of course you can use the R6 C API toolkit if you wish to.


            • thanks

              By bernard j devlin 2 decades ago

              I'll try to get round to learning how to do it with the C API toolkit in the next few weeks and let you know if I get it working on RedHat and Debian.

              Thanks for doing such great work for the rest of us!