• Unable to filter view metadata

    By Tinus Riyanto 4 years ago

    Hi Cameron, continuing yesterday's issue with view metadata is not filtered.
    My Designer Preferences (v9.0) are as follows :
    Binary DXL -> Off
    Auto Import -> Off
    Auto Export -> Off
    Build Automatically -> Off
    Swiper is activated, right click on the nsf and Swiper - Add Swiper menu is greyed out.
    Still using version 1.0 though.

    Test 1 : Modify said view and run Sync with ODP
    Result : Still unfiltered
    Test 2 : Build project and run Sync with ODP
    Result : Still unfiltered
    Test 3 : Right click on the view *done from left outline panel and choose filter selected. Then run Sync with ODP
    Result : Still unfiltered.

    • By Tinus Riyanto 4 years ago

      My bad, forgot to close SourceTree and re-opened. Try it again in a different view, test 1 and 2 still give the same result but test 3 apparently work.
      However that present me with a problem if I have to manually do this for each design element one by one.

      • By Cameron Gregor 4 years ago

        Hi Tinus,

        Unfortunately for swiper to work automatically 'Auto Export' must be on.
        I didn't really specify that in the video or readme so I will update the readme to mention this.

        This is due to the way the 'Designer Source Control' system is set up. When the right-click 'Team -> Sync with On-Disk Project' is used I don't have a way to be able to listen/ get involved.
        But when auto export is enabled, it should run during the build process which is when swiper can detect the changes in the on-disk project.

        I may be able to do a right-click on the project 'filter project'

        alternatively if the IBM team can include an extension point to add metadata filters to then I can make it work in all cases!

        • By Tinus Riyanto 4 years ago

          Hmm, next try then

          Auto Import : On
          Build Automatically : Off
          Restart designer just in case
          Test 4 : Modify another view and then do Sync with ODP
          Result : Still unfiltered

          Auto Import : On
          Build Automatically : On
          Restart designer again just in case
          Test 5 : Modify another view and then do Sync with ODP
          Result : Still unfiltered

          Even when I turned on auto import and auto build, the export to ODP process does not seemed to run automatically when I do any modification and hit save. Is there anything else missing ?

          • By Tinus Riyanto 4 years ago

            Sorry I mean auto export, not auto import.
            Grrr … I really wish there is a way to edit my own post.

            • By Cameron Gregor 4 years ago

              Hi Tinus, hmm the last scenario should have worked. Sorry that it is not working for you yet.

              Maybe I can have a look at the logs? can you do this:

              Go to File -> Swiper -> Start Logging
              Edit a View and save
              Check the File contents on Disk see if filtered
              If not filtered try right-click on project and 'Build'
              check file contents again
              Go to file -> Swiper ->Stop logging

              find the log file in your %HOME%/.swiper/swiper-log.0.0.xml
              create an issue 'View not being filtered' in github (use the defects link above) and attach the log file?