• Not really an OpenLog bug but...

    By John Marshall 1 decade ago

    I was trying to log an event and for some reason the event was not saving. After switching on debugging I was presented with this error message:



    OpenLogItem error: Notes error 4175: Couldn't get default View id for database ()



    Ok I had not defined a default view for my database as per the error message, fine. But why on earth would I need to access a default view in my database from within the OpenLogItem class. I eventually tracked it down to this line:



    Class: OpenLogItem

    Method: writeToLog

    Line: rtitem.appendDocLink(errDoc, errDoc.getUniversalID());



    It seems the call to appendDocLink requires a default view to be defined in the database you are logging otherwise it fails with a NotesException. As the debugging level in OpenLog is set by default to "0" I only noticed when my custom event messages failed to appear. Setting a default view in the database solved the problem.



    Sounds like a Domino Java feature to be aware of. Just thought I would let you know.

    • ...Tested Environment

      By John Marshall 1 decade ago

      I forgot to mention the environment I was using for testing:



      Windows 2000 Professional

      Domino Server Release 6.0.1 CF1



      The same behaviour may not be evident in other releases of Domino.

    • I think I've seen that sort of thing before...

      By Julian Robichaux 1 decade ago

      I know I've received some unexpected errors before when a default view/form hasn't been defined in a database. I guess that's one of them.



      I think I'll probably wrap that particular line in a try/catch block, so the whole routine won't fail when that happens. I have a few other things I'm working on for the next release, so I'll stick that in there as well.



      Good catch. Thanks for the info.


      • Julian