• CLFAD0305W: Cannot find the libraries (org.openntf.xsp.bootstrap.library,org.openntf.domino.xsp.XspLibrary) required by the application /Web/FileSilo.nsf

    By Ursus Schneider 2 months ago

    I am on the newest Domino Version (10.0.1FP1). I downloaded FileSilo from git and created a new .nsf on my development server. I then downloaded the latest ExtLib (wow, is it really from Nov. 6 2017 - seems quite old to me) - I then did a local import of the site and have version 9.0.1v09_02_20171023_1055 installed (I previously had 9.0.1v00 installed). When I now connect to the FileSilo.nsf I get the error in the subject. What am I doing wrong?

    PS: I did not have the newest extlib installed on my development client -> should I maybe have done that first?

    Doing a “tell http osgi ss com.ibm.xsp.extlib”:

    [0F20:0051-1318] 06.05.2019 21:42:24 Remote console command issued by Eins Automatrix/aqua: tell http osgi ss com.ibm.xsp.extlib
    [0184:0002-11DC] 06.05.2019 21:42:29 osgi> “Framework is launched.”
    [0184:0002-11DC] 06.05.2019 21:42:29 id State Bundle
    [0184:0002-11DC] 06.05.2019 21:42:29 12 INSTALLED com.ibm.xsp.extlib.domino_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 13 RESOLVED com.ibm.xsp.extlib.relational.nl2_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=246
    [0184:0002-11DC] 06.05.2019 21:42:29 15 ACTIVE com.ibm.xsp.extlibx_9.0.1.v00_16_20160119-2239
    [0184:0002-11DC] 06.05.2019 21:42:29 16 RESOLVED com.ibm.xsp.extlib.controls.nl2_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=241
    [0184:0002-11DC] 06.05.2019 21:42:29 17 RESOLVED com.ibm.xsp.extlib.domino.nl3_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=243
    [0184:0002-11DC] 06.05.2019 21:42:29 18 INSTALLED com.ibm.xsp.extlib.sample_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 21 RESOLVED com.ibm.xsp.extlib.core.nl2_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=242
    [0184:0002-11DC] 06.05.2019 21:42:29 22 RESOLVED com.ibm.xsp.extlibx.controls_9.0.1.v00_16_20160119-2239
    [0184:0002-11DC] 06.05.2019 21:42:29 24 RESOLVED com.ibm.xsp.extlib.oneui.nl1_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=245
    [0184:0002-11DC] 06.05.2019 21:42:29 28 INSTALLED com.ibm.xsp.extlib.core_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 29 RESOLVED com.ibm.xsp.extlib.oneui.nl2_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=245
    [0184:0002-11DC] 06.05.2019 21:42:29 31 INSTALLED com.ibm.xsp.extlib.oneui_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 34 RESOLVED com.ibm.xsp.extlib.relational.nl3_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=246
    [0184:0002-11DC] 06.05.2019 21:42:29 36 RESOLVED com.ibm.xsp.extlib.domino.nl1_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=243
    [0184:0002-11DC] 06.05.2019 21:42:29 38 RESOLVED com.ibm.xsp.extlib.core.nl3_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=242
    [0184:0002-11DC] 06.05.2019 21:42:29 42 INSTALLED com.ibm.xsp.extlib.controls_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 44 ACTIVE com.ibm.xsp.extlibx.theme.bootstrap4_9.0.1.v00_16_20160119-2239
    [0184:0002-11DC] 06.05.2019 21:42:29 47 RESOLVED com.ibm.xsp.extlib.controls.nl1_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=241
    [0184:0002-11DC] 06.05.2019 21:42:29 48 RESOLVED com.ibm.xsp.extlib.controls.nl3_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=241
    [0184:0002-11DC] 06.05.2019 21:42:29 50 INSTALLED com.ibm.xsp.extlib.mobile_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 52 RESOLVED com.ibm.xsp.extlib.domino.nl2_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=243
    [0184:0002-11DC] 06.05.2019 21:42:29 59 INSTALLED com.ibm.xsp.extlib.relational_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 60 RESOLVED com.ibm.xsp.extlib.mobile.nl3_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=244
    [0184:0002-11DC] 06.05.2019 21:42:29 63 INSTALLED com.ibm.xsp.extlib_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 64 RESOLVED com.ibm.xsp.extlib.oneui.nl3_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=245
    [0184:0002-11DC] 06.05.2019 21:42:29 67 RESOLVED com.ibm.xsp.extlib.relational.nl1_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=246
    [0184:0002-11DC] 06.05.2019 21:42:29 70 RESOLVED com.ibm.xsp.extlib.core.nl1_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=242
    [0184:0002-11DC] 06.05.2019 21:42:29 72 RESOLVED com.ibm.xsp.extlib.mobile.nl2_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=244
    [0184:0002-11DC] 06.05.2019 21:42:29 77 STARTING com.ibm.xsp.extlibx.core_9.0.1.v00_16_20160119-2239
    [0184:0002-11DC] 06.05.2019 21:42:29 81 RESOLVED com.ibm.xsp.extlib.mobile.nl1_9.0.1.v09_02_20171023-1055
    [0184:0002-11DC] 06.05.2019 21:42:29 Master=244
    [0184:0002-11DC] 06.05.2019 21:42:29 241 ACTIVE com.ibm.xsp.extlib.controls_10.0.1.v00_00_20181128-2143
    [0184:0002-11DC] 06.05.2019 21:42:29 Fragments=47, 16, 48
    [0184:0002-11DC] 06.05.2019 21:42:29 242 ACTIVE com.ibm.xsp.extlib.core_10.0.1.v00_00_20181128-2143
    [0184:0002-11DC] 06.05.2019 21:42:29 Fragments=38, 21, 70
    [0184:0002-11DC] 06.05.2019 21:42:29 243 ACTIVE com.ibm.xsp.extlib.domino_10.0.1.v00_00_20181128-2143
    [0184:0002-11DC] 06.05.2019 21:42:29 Fragments=36, 52, 17
    [0184:0002-11DC] 06.05.2019 21:42:29 244 ACTIVE com.ibm.xsp.extlib.mobile_10.0.1.v00_00_20181128-2143
    [0184:0002-11DC] 06.05.2019 21:42:29 Fragments=81, 60, 72
    [0184:0002-11DC] 06.05.2019 21:42:29 245 ACTIVE com.ibm.xsp.extlib.oneui_10.0.1.v00_00_20181128-2143
    [0184:0002-11DC] 06.05.2019 21:42:29 Fragments=24, 64, 29
    [0184:0002-11DC] 06.05.2019 21:42:29 246 ACTIVE com.ibm.xsp.extlib.relational_10.0.1.v00_00_20181128-2143
    [0184:0002-11DC] 06.05.2019 21:42:29 Fragments=34, 67, 13
    [0184:0002-11DC] 06.05.2019 21:42:29 247 STARTING com.ibm.xsp.extlib.sample_10.0.1.v00_00_20181128-2143
    [0184:0002-11DC] 06.05.2019 21:42:29 248 ACTIVE com.ibm.xsp.extlib_10.0.1.v00_00_20181128-2143

    • By Oliver Busse 2 months ago

      Did you built from master or from v10 branch? Only the v10 branch is free from extra plugins and runs on Domino 10. Please keep in mind that the Extlib from OpenNTF is not yet supported, only the internal from Domino 10 (in the v10 branch).

      • By Ursus Schneider 2 months ago

        Hi Oliver. Thank you for the prompt answer. I, of course, built from the master branch (didn't even change to the branch page) -> I'll build from the V10 branch this evening and report back here.

      • By Ursus Schneider 2 months ago

        Hi Oliver. Now the page loads but without BootStrap - it seems as if the bootstrap CDN is being loaded via HTTP and not HTTPS -> where can I change this -> somehow I cannot find it in the XPages nor the custom controls

        Here the error: index.xsp:7 Mixed Content: The page at 'https://develop.mydomain.com/Web/FileSilo.nsf/index.xsp' was loaded over HTTPS, but requested an insecure stylesheet 'http://maxcdn.bootstrapcdn.com/font-awesome/4.1.0/css/font-awesome.min.css'. This request has been blocked; the content must be served over HTTPS.

        • By Oliver Busse 2 months ago

          Hi Ursus,

          yeah that's a mistake. The resources are defined in the theme:
          https://github.com/zeromancer1972/FileSilo/blob/master/ODP/Resources/Themes/bootstrap3.theme

          • By Ursus Schneider 2 months ago

            Hi Oliver. I have the feeling your code is fine - there are two resources setup, one for http and one for https. The links are correct there. I have a reverse proxy setup which talks to the domino server using http, but has https outward facing. That is where the error comes in I think. I just changed both to https.

            I'm still having problems with the date picker though, any pointers maybe?

            Thank you for your help :)

            • By Oliver Busse 2 months ago

              Please check if the pre-built template works better for you. I just tested it. You can find it on the release page here.

      • By Ursus Schneider 2 months ago

        Ok, found the link in the file Theme/bootstrap3 - updated and restarted the server but it's still not working. Now I get:

        Failed to load resource: the server responded with a status of 404 (Not Found)

        for the following three css files:

        Web/FileSilo.nsf/xsp/.ibmmodres/.css/bootstrap-datepicker-master%2Fcss%2Fdatepicker3.css&bs3_tweaks.css

        /Web/FileSilo.nsf/xsp/.ibmmodres/.js/bootstrap-datepicker-master%2Fjs%2Fbootstrap-datepicker.js&fileinput%2Fbootstrap.file-input.js&core.js

        • By Oliver Busse 2 months ago

          I didn't check but I suspect it may be this issue I described here:
          https://oliverbusse.notesx.net/hp.nsf/blogpost.xsp?documentId=2F1A

          One or more resources are not available and therefor the whole URL returns a 404. To check which resource is missing disable resource aggregation in the XSP properties and check again with dev tools of your browser to identify the resource(s) that is(are) missing. If there is any please report as an issue in Github.

          • By Ursus Schneider 2 months ago

            The only thing I am seeing is:

            [Deprecation] Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help, check https://xhr.spec.whatwg.org/.
            req.getText @ dojo.js:307
            injectModule @ dojo.js:1522
            getModule @ dojo.js:1039
            defineModule @ dojo.js:1569
            def @ dojo.js:1805
            (anonymous) @ xspClientDojo.js:4729

            do you want me to create an issue? To be clear, the app still isn't working for my ATM.

            • By Oliver Busse 2 months ago

              Well, I never saw this issue before - you can create an issue of course, maybe someone else is able to solve it.