• kSpamCon does not work

    By Michael Kuethe 7 years ago

    Hello,

    I tries to install the kspam on Suse 9.3 with Domino 7.

    Well it work - and now the kspam is reading and calculating the mailgod and mailspam db's



    BUT:

    I've tried several configurations and rules but none of them becames active. It seems to be that the kSpamCon.nsf is not used!



    So I used the Notes.ini variables to configure kSpam. Well partly this works but I can't enter any rules! And even the configuration process is not very admin friendly ;-} At least the filter does not work. I've populated the mailspam.nsf with about 600 spammails - but nearly nothing happens. Only two field are added to the document (KS_ALLOW_REASON and KS_IID) - but no MARK.



    I've checked the filenames (yes case sensitive) -ok

    They ownership of the files is the same as the domino user.



    Here are the config variables:



    Extmgr_addins=libkspam.so

    ServerTasks=…..,kspam



    KS_IID=Fabrik

    KS_BAYESIAN_ACTION=1

    KS_BAYESIAN_ACTION_MARK_WITH=[ propably SPAM ]

    KS_BAYESIAN_BOUNDARY=90

    KS_BAYESIAN_FILTER=1

    KS_BAYESIAN_MARK=1

    KS_BAYESIAN_PREP=1



    KS_BAYESIAN_RATION=10

    KS_BL_DUMPLISTS=1



    KS_BL_PERIOD=60



    KS_DEFAULTACTION=1

    KS_MARK=1

    KS_RELOAD=1

    KS_STATS=1



    I would be very happy if someone could correct my mistake. I've tried my very best for a complete day - but now I'm helpless.





    regards



    Michael K├╝the

    • By Nico Vis 7 years ago

      Hi, which version of kspam are you using?

      Can you try with a copy & deny Rule?

      On Linux youn should name KSpamCon.nsf the configuration database, first letter Upper case.

      Let me know.

      Nico

      • thx

        By Michael Kuethe 7 years ago

        Hi,

        thanks for your attention.

        I'm running 17 b and it seems to be a configuration problem.

        I've created a link called KSpamCon.nsf and now it seems to work.

        In the moment I'm still wondering why the bayesian filter did not mark the incomming spam - the rules are now working.

        will the mark mechanism work, when the preparation mode is enabled (1 or2) is turned on?





        regards



        Michael